반응형

sudo apt upgrade 명령을 사용하여 우분투 패키지를 업그레이드 하려고 하는데 다음과 같은 에러가 발생했습니다. 

 

다음 패키지의 의존성이 맞지 않습니다:
 grub-efi-amd64-signed : 의존: grub-efi-amd64-bin (= 2.06-2ubuntu7)

 

 

구글링하여 찾은 방법으로 해결했습니다.

https://askubuntu.com/a/1431837

 

문제가 되는 grub-efi-amd64-signed 패키지만 다음처럼 따로 설치해줍니다. 

sudo apt --only-upgrade install grub-efi-amd64-signed

 

위 명령으로 설치후, 마지막에 보인 다음 메시지가 문제가 될까 염려를 했지만

grub-install: 경고: You will have to complete the GRUB setup manually.

 

우분트를 재부팅하는데 문제가 없었습니다.

 

다시 sudo apt upgrade 명령을 해보니 정상적으로 패키지들이 업그레이드되었고 다시 재부팅해도 문제가 없었습니다. 

 

 

 

 


 

 

 

 

 

 

반응형

진행해본 결과물을 기록 및 공유하는 공간입니다.
잘못된 부분이나 개선점을 알려주시면 반영하겠습니다.


소스코드 복사시 하단에 있는 앵커 광고의 왼쪽 위를 클릭하여 닫은 후 해야 합니다.


문제가 생기면 포스트와 바뀐 환경이 있나 먼저 확인해보세요.
질문을 남겨주면 가능한 빨리 답변드립니다.


제가 쓴 책도 한번 검토해보세요 ^^

  • 네이버 블러그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 카카오스토리 공유하기

댓글을 달아 주세요

TistoryWhaleSkin3.4">